Reminder Secure

Canon 580EXII no comms with 5DMKII

Darrin Henry Photography is off-lineSilver Member
06 November 2014 05:16
darrinhenry
Photographer
darrinhenry
Location
United Kingdom
London
London

A child recently knocked into my camera, Canon 5DMKII, recently while out on a shoot. I had the external flash on at the time. Since then the camera seems to have problems communicating with the flash unit, ie, not triggering the flash when attached. Every now and again, when I connect it up to try, it will fire just the once, and then no more.
I've tested the speedlight on another body (40D) and it works fine.

I've also tried another Canon speedlight on the 5DMKII, a 430EX and this has the same problem of not seeming to be able to communicate.


The Yongnuo speedlights which I also use, these continue to operate fine, nothing different.

It appears to be a problem with the 5DMKII body having problems communicating with genuine Canon flash speedlights.
Has anyone else experienced this and any suggestions? A simple quick fix seems a long shot, but you never know... might as well ask

cheers
Darrin Henry Photography


Steven Jardine is off-linePlatinum Member
06 November 2014 05:32
RedChecker
Photographer
RedChecker
Location
United Kingdom
Buckinghamshire
Stoke Mandeville

Probably won't help but I'd give the flash contacts (camera and flash) a clean with a soft pencil rubber just in case it's a contact issue.
When you are dead, you do not know that you are dead. All of your pain is felt by others. The same thing happens when you are stupid.


Darrin Henry Photography is off-lineSilver Member
06 November 2014 06:08
darrinhenry
Photographer
darrinhenry
Location
United Kingdom
London
London

Thanks - I should have mentioned I've already tried giving all the contacts a good clean. Didn't make any difference.
Darrin Henry Photography


Steven Jardine is off-linePlatinum Member
06 November 2014 06:17
RedChecker
Photographer
RedChecker
Location
United Kingdom
Buckinghamshire
Stoke Mandeville

Is the Yongnuo a 'dumb' flashgun (ie. single pin) or does it have TTL data pins?

If the former then one or more of the data contacts on the camera are probably damaged.
When you are dead, you do not know that you are dead. All of your pain is felt by others. The same thing happens when you are stupid.


Paul Riddell is off-line
06 November 2014 06:30
riddell
Photographer
riddell
Location
United Kingdom
Hertfordshire
berkhamsted


It sounds like the camera is damaged one way or another.

www.photographybyriddell.co.uk


Darrin Henry Photography is off-lineSilver Member
06 November 2014 06:46
darrinhenry
Photographer
darrinhenry
Location
United Kingdom
London
London

Quote from RedChecker
Is the Yongnuo a 'dumb' flashgun (ie. single pin) or does it have TTL data pins? If the former then one or more of the data contacts on the camera are probably damaged.



Yes, it's 'dumb' as you put it, single pin. Sadly I think it's a camera fault also. Everything else though works fine. Real pain as I wanted to use the 2nd curtain facility for a shoot.
Darrin Henry Photography


Mark Carr is off-line
08 November 2014 04:02
MCPhotos
Photographer

Location
United Kingdom
Cumbria
Grange Over Sands

I had exactly the same issue with the same combination of kit last year - On mine I was working and the tripod gave way and the head rotated causing the camera to drop against one of the legs and The flash took the force of the blow it was a problem with the additional TTL pins and had to send the body for a professional repair - not good news re q quick fix !


Darrin Henry Photography is off-lineSilver Member
11 November 2014 14:52
darrinhenry
Photographer
darrinhenry
Location
United Kingdom
London
London

Quote from MCPhotos
I had exactly the same issue with the same combination of kit last year - On mine I was working and the tripod gave way and the head rotated causing the camera to drop against one of the legs and The flash took the force of the blow it was a problem with the additional TTL pins and had to send the body for a professional repair - not good news re q quick fix !



Yeah, it was a long shot hoping for a simple fix, but sometimes you can be lucky. Not this time unfortunately. I'm back in UK in March next year for a bit, will have to see about taking it for repairs then. Planning to upgrade to the MKIII anyway, so depending on possible repair costs otherwise this one will be fine as a second cam.
Darrin Henry Photography



31 Users currently online   Blue=Models Orange=Photographers Red=Agencies Purple=MUA/Stylists Grey=Studios Green=Moderators
ElleLaura Jessica_Knight RoxyMendez Winterlilly
antoinewynn chopper_images colinpierce csk_photography djb1 Essexjohn eyecandiphotography GGDP_Photography hylander ignite JohnDentonPhoto keltica lify MIB nickdandalos Njsphotography panda49 paulq photosareu psn redbaron sniffer stevegosh TinDolls Tricky7 VB_Photo Vinceb